Threat Feed
Daily intelligence on vulnerabilities, threat actors and geopolitical context — distilled from primary sources.
Filtered Reports
16 / 16 results
criticalbug_reportVulnerabilityGitLab CVSS 10.0 RCE affects all self-managed versions since 2014
GitLab self-managed installations versions 7.0 (released 2014) through 19.5.0. Fixed in 19.5.1, 19.4.3, 19.3.6, 19.2.9, 19.1.9, 19.0.10, and 18.11.13. GitLab.com and GitLab Dedicated tenants on internal releases 19.3.5-internal0 and 19.4.2-internal0…
criticalbug_reportVulnerabilityGitLab CE/EE critical vulnerability requires immediate patching
GitLab Community Edition (CE) and Enterprise Edition (EE). Specific affected versions not disclosed in available advisory text. CVE identifier not yet assigned or published.
criticalbug_reportVulnerabilityGitLab CE/EE critical RCE (CVE-2026-97229) allows unauthenticated code execution
GitLab Community Edition (CE) and Enterprise Edition (EE) self-managed instances: versions before 19.4.2, before 19.3.4, and before 19.2.8. The critical vulnerability CVE-2026-97229 (CVSS 10.0) affects the CI/CD regular expression compiler.
criticalbug_reportVulnerabilityGitLab CI/CD regex compiler RCE allows unauthenticated code execution
GitLab Community Edition (CE) and Enterprise Edition (EE) versions 19.2 before 19.2.8, 19.3 before 19.3.4, and 19.4 before 19.4.2. Self-managed instances are affected. GitLab.com and GitLab Dedicated are already patched.
criticalbug_reportVulnerabilityGitLab AI Gateway RCE flaw (CVE-2026-90970) affects self-hosted instances
GitLab AI Gateway versions 18.1.6 through 19.4.0 on self-hosted deployments. Authenticated users with Duo Agent Platform access can exploit. GitLab.com, GitLab Dedicated, and self-managed instances using GitLab-hosted gateways are NOT affected.
criticalbug_reportVulnerabilityGitLab AI Gateway critical RCE allows arbitrary command execution
GitLab AI Gateway service. Specific affected versions not disclosed in available information. Impacts organizations running GitLab instances with AI Gateway enabled.
criticalbug_reportVulnerabilityGitLab RCE vulnerabilities require immediate patching per CERT.BE
GitLab (specific versions not provided in advisory). Remote Code Execution vulnerabilities affect GitLab instances. CVE identifiers not specified in available information.
highbug_reportVulnerabilityGitLab issue email token enables code commits and CI/CD execution as user
GitLab.com (all accounts) and self-managed GitLab instances with incoming email enabled (default). GitLab Dedicated appears unaffected. All user roles affected, with impact severity scaling to account permissions (Guest minimal, Maintainer critical).
criticalbug_reportVulnerabilityGitLab CE/EE path traversal vulnerability requires immediate patching
GitLab Community Edition (CE) and Enterprise Edition (EE). Specific affected versions not disclosed in available information.
criticalbug_reportVulnerabilityGitLab CVSS 10.0 path traversal allows unauthenticated file read
GitLab Community Edition (CE) and Enterprise Edition (EE): all versions 18.7 to 19.1.7, 19.2.0 to 19.2.5, and 19.3.0 to 19.3.1. Requires at least one public project to exist on the instance.
criticalbug_reportVulnerabilityGitLab path traversal CVE-2026-85706 requires immediate patching
GitLab servers (specific affected versions not disclosed in available data). Path traversal vulnerability with maximum severity rating (CVSS 10.0 assumed).
criticalbug_reportVulnerabilityGitLab CVE-2026-19478 code injection under active exploitation
GitLab Community Edition (CE) and Enterprise Edition (EE): versions 18.2 before 18.11.11, 19.0 before 19.0.8, 19.1 before 19.1.6, and 19.2 before 19.2.4. Affects self-hosted instances with publicly accessible projects.
criticalbug_reportVulnerabilityGitLab CE/EE critical code injection flaw with public PoC exploit
GitLab Community Edition (CE) and Enterprise Edition (EE). Specific affected versions not provided in source material. CVE identifier not yet assigned or disclosed.
criticalbug_reportVulnerabilityCritical GitLab GraphQL flaw allows unauthenticated project deletion
GitLab Community Edition (CE) and Enterprise Edition (EE) self-managed installations: all versions from 18.2 before 18.11.11, 19.0 before 19.0.8, 19.1 before 19.1.6, and 19.2 before 19.2.4.
highbug_reportVulnerabilityGitLab RCE PoC published for unpatched self-managed instances ≤18.11.3
GitLab CE/EE self-managed instances: versions 15.2.0–18.10.7, 18.11.0–18.11.4, and 19.0.0–19.0.1. All tiers (Free through Ultimate) affected. Underlying flaw in Oj gem 3.13.0–3.17.1. GitLab.com SaaS not affected.
highbug_reportVulnerabilityMultiple high-severity vulnerabilities in GitLab CE and EE require patching
GitLab Community Edition (CE) and Enterprise Edition (EE). Specific affected versions not provided in advisory; typically affects versions prior to latest security release.